GHSA-8qrh-h9m2-5fvf

Cross site scripting that affects rails

At a glance

Published
Updated
CVE
CVE-2009-3009

Description

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Affected packages

PackageVersions
RubyGems · actionpackintroduced 2.0.0, fixed 2.2.3
RubyGems · actionpackintroduced 2.3.0, fixed 2.3.4
RubyGems · activesupportintroduced 2.0.0, fixed 2.2.3
RubyGems · activesupportintroduced 2.3.0, fixed 2.3.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database