GHSA-8q59-q68h-6hv4

Improper Input Validation in PyYAML

At a glance

Published
Updated
CVE
CVE-2020-14343
Aliases
PYSEC-2021-142
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

A vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. This flaw allows an attacker to execute arbitrary code on the system by abusing the python/object/new constructor. This flaw is due to an incomplete fix for CVE-2020-1747.

Affected packages

PackageVersions
PyPI · pyyamlintroduced 0, fixed 5.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database