GHSA-8jj2-x2gc-ggm7

Drupal Core Cross-site scripting vulnerability

At a glance

Published
Updated
CVE
CVE-2020-13666
Aliases
BIT-drupal-2020-13666, DRUPAL-CORE-2020-007
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

Affected packages

PackageVersions
Packagist · drupal/coreintroduced 8.8.0, fixed 8.8.10
Packagist · drupal/coreintroduced 8.9.0, fixed 8.9.6
Packagist · drupal/coreintroduced 9.0.0, fixed 9.0.6
Packagist · drupal/coreintroduced 7.0.0, fixed 7.73
Packagist · drupal/drupalintroduced 7.0.0, fixed 7.73
Packagist · drupal/drupalintroduced 8.8.0, fixed 8.8.10
Packagist · drupal/drupalintroduced 8.9.0, fixed 8.9.6
Packagist · drupal/drupalintroduced 9.0.0, fixed 9.0.6

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database