GHSA-8jhp-2gcr-qw96

Moodle vulnerable to RCE via unsafe deserialization

En bref

Publiée
Mise à jour
CVE
CVE-2021-3943
Alias
BIT-moodle-2021-3943
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A remote code execution risk when restoring backup files was identified.

Paquets affectés

PaquetVersions
Packagist · moodle/moodleintroduced 3.11, fixed 3.11.4
Packagist · moodle/moodleintroduced 3.10, fixed 3.10.8
Packagist · moodle/moodleintroduced 3.9, fixed 3.9.11

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database