GHSA-8fg4-j562-mjrc

Improper Input Validation in Apache Airflow resulting in Remote Code Execution

At a glance

Published
Updated
CVE
CVE-2017-15720
Aliases
PYSEC-2019-147
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

In Apache Airflow 1.8.2 and earlier, an authenticated user can execute code remotely on the Airflow webserver by creating a special object.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 1.9.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database