GHSA-8fg4-j562-mjrc
Improper Input Validation in Apache Airflow resulting in Remote Code Execution
At a glance
- Published
- Updated
- CVE
- CVE-2017-15720
- Aliases
- PYSEC-2019-147
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
In Apache Airflow 1.8.2 and earlier, an authenticated user can execute code remotely on the Airflow webserver by creating a special object.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 1.9.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-15720 ADVISORY
- https://github.com/apache/airflow/commit/04cacdd0a7526927137b452f38c3e894a5d2ce4a WEB
- https://github.com/apache/airflow/commit/daa281c0364609d6812921123cf47e4118b40484 WEB
- https://github.com/advisories/GHSA-8fg4-j562-mjrc ADVISORY
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-147.yaml WEB
- https://lists.apache.org/thread.html/ade4d54ebf614f68dc81a08891755e60ea58ba88e0209233eeea5f57@%3Cdev.airflow.apache.org%3E WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |