GHSA-8f57-wcmg-4jmh
Apache Airflow vulnerable to Exposure of Resource to Wrong Sphere
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-48291
- Alias
- BIT-airflow-2023-48291, PYSEC-2023-265
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Description
Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2 Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.8.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-48291 ADVISORY
- https://github.com/apache/airflow/pull/34366 WEB
- https://github.com/apache/airflow/commit/4f1b500c47813c54349b7d3e48df0a444fb4826c WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-265.yaml WEB
- https://lists.apache.org/thread/3nl0h014274yjlt1hd02z0q78ftyz0z3 WEB
- http://www.openwall.com/lists/oss-security/2023/12/21/1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |