GHSA-8cw5-rv98-5c46

Arbitrary PHP code execution in Drupal

At a glance

Published
Updated
CVE
CVE-2019-6339
Aliases
DRUPAL-CORE-2019-002
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6, and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted phar:// URI. Some Drupal code (core, contrib, and custom) may be performing file operations on insufficiently validated user input, thereby being exposed to this vulnerability. This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.

Affected packages

PackageVersions
Packagist · drupal/drupalintroduced 7.0.0, fixed 7.62.0
Packagist · drupal/drupalintroduced 8.0.0, fixed 8.5.9
Packagist · drupal/drupalintroduced 8.6.0, fixed 8.6.6
Packagist · drupal/coreintroduced 7.0.0, fixed 7.62.0
Packagist · drupal/coreintroduced 8.0.0, fixed 8.5.9
Packagist · drupal/coreintroduced 8.6.0, fixed 8.6.6

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database