GHSA-87qx-g5wg-mwmj

RubyGems Cross-site Scripting vulnerability

At a glance

Published
Updated
CVE
CVE-2018-1000078
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack requires the victim to browse to a malicious gem on a vulnerable gem server. This vulnerability is fixed in 2.7.6.

Affected packages

PackageVersions
RubyGems · rubygems-updateintroduced 0, fixed 2.7.6
Maven · org.jruby:jruby-stdlibintroduced 0, fixed 9.1.16.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database