GHSA-876p-4wgc-75rx

Apache Struts RCE Vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2016-0785
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Apache Struts 2.x before 2.3.20.3, 2.3.24.3, and 2.3.28 allows remote attackers to execute arbitrary code via a `%{}` sequence in a tag attribute, aka forced double OGNL evaluation.

Paquets affectés

PaquetVersions
Maven · org.apache.struts:struts2-coreintroduced 2.0.0, fixed 2.3.20.3
Maven · org.apache.struts:struts2-coreintroduced 2.3.24, fixed 2.3.24.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database