GHSA-86vp-x3pr-79rx

Apache Airflow cross-site scripting due to incomplete fix for CVE-2020-13944

En bref

Publiée
Mise à jour
CVE
CVE-2020-17515
Alias
BIT-airflow-2020-17515, PYSEC-2020-21
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

The `origin` parameter passed to some of the endpoints like `/trigger` was vulnerable to XSS exploit. This issue affects Apache Airflow versions prior to 1.10.15. This is same as CVE-2020-13944 but the implemented fix in Airflow 1.10.13 did not fix the issue completely.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 1.10.15rc1
PyPI · apache-airflowintroduced 2.0.0b1, fixed 2.0.2rc1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database