GHSA-85xw-3hp5-6fmc

Magento 2 Community Edition XSS Vulnerability

At a glance

Published
Updated
CVE
CVE-2019-8138
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can execute arbitrary JavaScript code by providing arbitrary API endpoint that will not be chcecked by sale pickup event.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.2.0, fixed 2.2.10
Packagist · magento/community-editionintroduced 2.3.0, fixed 2.3.2-p1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database