GHSA-85pf-r4c7-3j9r

Apache Airflow Drill Provider vulnerable to improper input validation

At a glance

Published
Updated
CVE
CVE-2023-28707
Aliases
PYSEC-2023-3, PYSEC-2026-1136
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Apache Software Foundation's Apache Airflow Drill Provider before 2.3.2 is vulnerable to improper input validation because the host passed in drill connection is not sanitized.

Affected packages

PackageVersions
PyPI · apache-airflow-providers-apache-drillintroduced 0, fixed 2.3.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database