GHSA-7xqv-jgv6-x2h8

Magento 2 Community Edition XSS Vulnerability

At a glance

Published
Updated
CVE
CVE-2019-7881
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

A cross-site scripting mitigation bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user to escalate privileges (admin vs. admin XSS attack).

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.1, fixed 2.1.18
Packagist · magento/community-editionintroduced 2.2, fixed 2.2.9
Packagist · magento/community-editionintroduced 2.3, fixed 2.3.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database