GHSA-7w95-qwhh-q9p3

Magento Path Traversal vulnerability via the `theme[preview_image]` parameter

En bref

Publiée
Mise à jour
CVE
CVE-2021-36031

Description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by a Path Traversal vulnerability via the `theme[preview_image]` parameter. An attacker with admin privileges could leverage this vulnerability to achieve remote code execution.

Paquets affectés

PaquetVersions
Packagist · magento/project-community-editionintroduced 0, last affected 2.0.2
Packagist · magento/community-editionintroduced 0, fixed 2.3.7-p1
Packagist · magento/community-edition2.3.7
Packagist · magento/community-editionintroduced 2.4.2-p1, fixed 2.4.2-p2
Packagist · magento/community-edition2.4.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database