GHSA-7vx9-xjhr-rw6h

Cross-site Scripting in Eclipse Jetty

En bref

Publiée
Mise à jour
CVE
CVE-2019-10241
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

In Eclipse Jetty version 9.2.26 and older, 9.3.25 and older, and 9.4.15 and older, the server is vulnerable to XSS conditions if a remote client USES a specially formatted URL against the DefaultServlet or ResourceHandler that is configured for showing a Listing of directory contents.

Paquets affectés

PaquetVersions
Maven · org.eclipse.jetty:jetty-serverintroduced 0, fixed 9.2.27.v20190403
Maven · org.eclipse.jetty:jetty-serverintroduced 9.3.0, fixed 9.3.26.v20190403
Maven · org.eclipse.jetty:jetty-serverintroduced 9.4.0, fixed 9.4.16.v20190411

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database