GHSA-7vpq-g998-qpv7

Netty denial of service vulnerability

At a glance

Published
Updated
CVE
CVE-2014-0193

Description

`WebSocket08FrameDecoder` in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a `TextWebSocketFrame` followed by a long stream of `ContinuationWebSocketFrames`.

Affected packages

PackageVersions
Maven · io.netty:nettyintroduced 3.6.0.Beta1, fixed 3.6.9.Final
Maven · io.netty:nettyintroduced 3.7.0.Final, fixed 3.7.1.Final
Maven · io.netty:nettyintroduced 3.8.0.Final, fixed 3.8.2.Final
Maven · io.netty:nettyintroduced 3.9.0.Final, fixed 3.9.1.Final
Maven · io.netty:nettyintroduced 4.0.0.Alpha1, fixed 4.0.19.Final
Maven · io.netty:netty-allintroduced 4.0.0.Alpha1, fixed 4.0.19.Final

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database