GHSA-7r83-w6r8-fh6w

Reflected Cross-site Scripting (XSS) in ACS Commons

At a glance

Published
Updated
CVE
CVE-2021-21028, CVE-2021-21043
Aliases
GHSA-f92j-qf46-p6vm
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

ACS Commons version 4.9.2 (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful.

Affected packages

PackageVersions
Maven · com.adobe.acs:acs-aem-commonsintroduced 0, fixed 4.10.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database