GHSA-7pwc-h2j2-rjgj
Apache Thrift has an Improper Validation of Certificate with Host Mismatch Vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2026-43869
- Aliases
- BIT-thrift-2026-43869
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Description
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version [0.23.0](https://github.com/apache/thrift/releases/tag/v0.23.0), which fixes the issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.thrift:libthrift | introduced 0, fixed 0.23.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-43869 ADVISORY
- https://github.com/apache/thrift/commit/0919c3d5506151514e283a63e1fe1ce83e2449d8 WEB
- https://github.com/apache/thrift PACKAGE
- https://github.com/apache/thrift/releases/tag/v0.23.0 WEB
- https://lists.apache.org/thread/3hsgl1b69wzq3ry39scqbv2dhyl3j52r WEB
- http://www.openwall.com/lists/oss-security/2026/05/05/3 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |