GHSA-7h26-63m7-qhf2

HTML comments vulnerability allowing to execute JavaScript code

At a glance

Published
Updated
CVE
CVE-2021-41165
Aliases
BIT-drupal-2021-41165
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L

Description

### Affected packages The vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. ### Impact A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. ### Patches The problem has been recognized and patched. The fix will be available in version 4.17.0. ### For more information Email us at security@cksource.com if you have any questions or comments about this advisory. ### Acknowledgements The CKEditor 4 team would like to thank William Bowling ([wbowling](https://github.com/wbowling)) for recognizing and reporting this vulnerability.

Affected packages

PackageVersions
npm · ckeditor4introduced 0, fixed 4.17.0
Packagist · ckeditor/ckeditorintroduced 0, fixed 4.17.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database