GHSA-7gcp-2gmq-w3xh

RubyGems Code Injection vulnerability

At a glance

Published
Updated
CVE
CVE-2017-0899
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

RubyGems prior to 2.6.13 is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

Affected packages

PackageVersions
RubyGems · rubygems-updateintroduced 0, fixed 2.6.13

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database