GHSA-7g95-jmg9-h524

Jenkins cross-site request forgery (CSRF) vulnerability

At a glance

Published
Updated
CVE
CVE-2025-27624
Aliases
BIT-jenkins-2025-27624
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L

Description

Jenkins 2.499 and earlier, LTS 2.492.1 and earlier does not require POST requests for the HTTP endpoint toggling collapsed/expanded status of sidepanel widgets (e.g., Build Queue and Build Executor Status widgets), resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to have users toggle their collapsed/expanded status of sidepanel widgets. Additionally, as the API accepts any string as the identifier of the panel ID to be toggled, attacker-controlled content can be stored in the victim’s user profile in Jenkins. Jenkins 2.500, LTS 2.492.2 requires POST requests for the affected HTTP endpoint.

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.493, fixed 2.500
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.492.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database