GHSA-7g95-jmg9-h524
Jenkins cross-site request forgery (CSRF) vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2025-27624
- Aliases
- BIT-jenkins-2025-27624
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Description
Jenkins 2.499 and earlier, LTS 2.492.1 and earlier does not require POST requests for the HTTP endpoint toggling collapsed/expanded status of sidepanel widgets (e.g., Build Queue and Build Executor Status widgets), resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to have users toggle their collapsed/expanded status of sidepanel widgets. Additionally, as the API accepts any string as the identifier of the panel ID to be toggled, attacker-controlled content can be stored in the victim’s user profile in Jenkins. Jenkins 2.500, LTS 2.492.2 requires POST requests for the affected HTTP endpoint.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.493, fixed 2.500 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.492.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-27624 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/84ef1a4d4db17d0ce66522d0141f6e52e2a4c97c WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://www.jenkins.io/security/advisory/2025-03-05/#SECURITY-3498 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |