GHSA-7ffh-cjvg-fpr4

Drupal Settings Tray access bypass

En bref

Publiée
Mise à jour
CVE
CVE-2017-6931
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Description

In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.

Paquets affectés

PaquetVersions
Packagist · drupal/coreintroduced 8.4.0, fixed 8.4.5
Packagist · drupal/drupalintroduced 8.4.0, fixed 8.4.5

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database