GHSA-7c34-32v3-j575
Payload relationship-query authorization bypass
At a glance
- Published
- Updated
- CVE
- CVE-2026-105852
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Description
## Impact A readable collection could expose information about protected documents in a related collection. **You are affected if:** - You expose a readable collection with a relationship to a collection protected by access.read where constraints. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds There is no complete workaround. Upgrade Payload packages `>= 3.90.0` or `>= 4.0.0-canary.34`.
Affected packages
| Package | Versions |
|---|---|
| npm · payload | introduced 0, fixed 3.90.0 |
| npm · payload | introduced 4.0.0-canary.0, fixed 4.0.0-canary.34 |
References
- https://github.com/payloadcms/payload/security/advisories/GHSA-7c34-32v3-j575 WEB
- https://github.com/payloadcms/payload/commit/94059cf4bc6170ce88453015c0c6551329ae3982 WEB
- https://github.com/payloadcms/payload PACKAGE
- https://github.com/payloadcms/payload/releases/tag/v3.90.0 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |