GHSA-78fp-cf4h-g36p

Duplicate Advisory: vLLM introduced enhanced protection for CVE-2025-62164

Withdrawn ·

At a glance

Published
Updated
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-mcmc-2m55-j8jj. This link is maintained to preserve external references. ### Original Description vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.

Affected packages

PackageVersions
PyPI · vllmintroduced 0.10.2, fixed 0.13.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database