GHSA-78fm-qhh8-8858

Moodle reflected XSS

At a glance

Published
Updated
CVE
CVE-2021-32478
Aliases
BIT-moodle-2021-32478
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.

Affected packages

PackageVersions
Packagist · moodle/moodleintroduced 3.10, fixed 3.10.4
Packagist · moodle/moodleintroduced 3.9, fixed 3.9.7
Packagist · moodle/moodleintroduced 3.8, fixed 3.8.9

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database