GHSA-7889-rm5j-hpgg

Clipboard feature vulnerability allowing to inject arbitrary HTML into the editor using paste functionality

En bref

Publiée
Mise à jour
CVE
CVE-2021-32809
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Description

### Affected packages The vulnerability has been discovered in [clipboard](https://ckeditor.com/cke4/addon/clipboard) plugin. All plugins with [clipboard](https://ckeditor.com/cke4/addon/clipboard) plugin dependency are affected: * [clipboard](https://ckeditor.com/cke4/addon/clipboard) * [pastetext](https://ckeditor.com/cke4/addon/pastetext) * [pastetools](https://ckeditor.com/cke4/addon/pastetools) * [widget](https://ckeditor.com/cke4/addon/widget) * [uploadwidget](https://ckeditor.com/cke4/addon/uploadwidget) * [autolink](https://ckeditor.com/cke4/addon/autolink) * [tableselection](https://ckeditor.com/cke4/addon/tableselection) ### Impact A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. ### Patches The problem has been recognized and patched. The fix will be available in version 4.16.2. ### For more information Email us at security@cksource.com if you have any questions or comments about this advisory. ### Acknowledgements The CKEditor 4 team would like to thank Anton Subbotin ([skavans](https://github.com/skavans)) for recognizing and reporting this vulnerability.

Paquets affectés

PaquetVersions
npm · ckeditor4introduced 4.5.2, fixed 4.16.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database