GHSA-74vq-h4q8-x6jv

Ansible Path Traversal vulnerability

At a glance

Published
Updated
CVE
CVE-2019-3828
Aliases
PYSEC-2019-5
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Description

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

Affected packages

PackageVersions
PyPI · ansibleintroduced 0, fixed 2.5.15
PyPI · ansibleintroduced 2.6.0a1, fixed 2.6.14
PyPI · ansibleintroduced 2.7.0a1, fixed 2.7.8

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database