GHSA-74pv-v9gh-h25p

RubyGems Infinite Loop vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2018-1000075
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

Paquets affectés

PaquetVersions
RubyGems · rubygems-updateintroduced 0, fixed 2.7.6
Maven · org.jruby:jruby-stdlibintroduced 0, fixed 9.1.16.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database