GHSA-746v-hfh2-xphm

Remote code execution in Apache Airflow Docker's Provider

At a glance

Published
Updated
CVE
CVE-2022-38362
Aliases
PYSEC-2026-773
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Apache Airflow Docker's Provider prior to 3.0.0 shipped with an example DAG that was vulnerable to (authenticated) remote code exploit of code on the Airflow worker host. Disable loading of example DAGs or upgrade apache-airflow-providers-docker to 3.0.0 or above.

Affected packages

PackageVersions
PyPI · apache-airflow-providers-dockerintroduced 0, fixed 3.0.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database