GHSA-742j-jcfr-23w3
Insufficient Session Expiration in Jenkins
At a glance
- Published
- Updated
- CVE
- CVE-2019-1003049
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Users who cached their CLI authentication before Jenkins was updated to 2.150.2 and newer, or 2.160 and newer, would remain authenticated in Jenkins 2.171 and earlier and Jenkins LTS 2.164.1 and earlier, because the fix for CVE-2019-1003004 in these releases did not reject existing remoting-based CLI authentication caches.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.164.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.165, fixed 2.172 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-1003049 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/0eeaa087aac192fb39f52928be5a5bbf16627ea6 WEB
- https://access.redhat.com/errata/RHBA-2019:1605 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2019-04-10/#SECURITY-1289 WEB
- https://www.oracle.com/security-alerts/cpuapr2022.html WEB
- http://www.securityfocus.com/bid/107901 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |