GHSA-742j-jcfr-23w3

Insufficient Session Expiration in Jenkins

At a glance

Published
Updated
CVE
CVE-2019-1003049
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Users who cached their CLI authentication before Jenkins was updated to 2.150.2 and newer, or 2.160 and newer, would remain authenticated in Jenkins 2.171 and earlier and Jenkins LTS 2.164.1 and earlier, because the fix for CVE-2019-1003004 in these releases did not reject existing remoting-based CLI authentication caches.

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.164.2
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.165, fixed 2.172

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database