GHSA-73w7-6w9g-gc8w

RubyGems has Origin Validation Error vulnerability

At a glance

Published
Updated
CVE
CVE-2017-0902
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

Affected packages

PackageVersions
RubyGems · rubygems-updateintroduced 0, fixed 2.6.13

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database