GHSA-6x49-w35h-wqrj

Bypass serialize checks in Apache Dubbo

At a glance

Published
Updated
CVE
CVE-2023-29234
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4. Users are recommended to upgrade to the latest version, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.dubbo:dubbointroduced 3.1.0, fixed 3.1.11
Maven · org.apache.dubbo:dubbointroduced 3.2.0, fixed 3.2.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database