GHSA-6vc8-3xf2-qrxx

Magento 2 Community Edition RCE Vulnerability

At a glance

Published
Updated
CVE
CVE-2019-8232
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Description

In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenticated user with administrative privileges for the import feature can execute arbitrary code through a race condition that allows webserver configuration file modification.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.2.0, fixed 2.2.10
Packagist · magento/community-editionintroduced 2.3.0, fixed 2.3.2-p1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database