GHSA-6qh6-v99h-vh4c

Magento 2 Community Edition RCE Vulnerability

At a glance

Published
Updated
CVE
CVE-2019-7876
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to manipulate layouts can insert a malicious payload into the layout.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.1, fixed 2.1.18
Packagist · magento/community-editionintroduced 2.2, fixed 2.2.9
Packagist · magento/community-editionintroduced 2.3, fixed 2.3.2
Packagist · magento/product-community-editionintroduced 2.1, fixed 2.1.18
Packagist · magento/product-community-editionintroduced 2.2, fixed 2.2.9
Packagist · magento/product-community-editionintroduced 2.3, fixed 2.3.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database