GHSA-6pw3-8h9w-32gc

Apache Airflow vulnerable to OS Command Injection via example DAGs

En bref

Publiée
Mise à jour
CVE
CVE-2022-40127
Alias
BIT-airflow-2022-40127, PYSEC-2022-42982
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

A vulnerability in Example Dags of Apache Airflow allows an attacker with UI access who can trigger DAGs, to execute arbitrary commands via manually provided run_id parameter. This issue affects Apache Airflow versions prior to 2.4.0.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.4.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database