GHSA-6pjx-3pjc-mrj8

Apache Thrift Python bindings have an Improper Handling of Highly Compressed Data (Data Amplification) vulnerability

At a glance

Published
Updated
CVE
CVE-2026-41608
Aliases
BIT-thrift-2026-41608, PYSEC-2026-3925
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Affected packages

PackageVersions
PyPI · thriftintroduced 0, fixed 0.24.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database