GHSA-6pjx-3pjc-mrj8
Apache Thrift Python bindings have an Improper Handling of Highly Compressed Data (Data Amplification) vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2026-41608
- Aliases
- BIT-thrift-2026-41608, PYSEC-2026-3925
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Affected packages
| Package | Versions |
|---|---|
| PyPI · thrift | introduced 0, fixed 0.24.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-41608 ADVISORY
- https://github.com/apache/thrift PACKAGE
- https://lists.apache.org/thread/7v3jhgwfbmhx42424phydlnzb109g8b9 WEB
- https://lists.apache.org/thread/vwsbcwqdpwdtp8qkjo11ol6rodbfm21f WEB
- http://www.openwall.com/lists/oss-security/2026/07/24/32 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |