GHSA-6p2c-69cv-3fxq
pgAdmin 4: Stored cross-site scripting (XSS) vulnerability in Browser Tree and Explain Visualizer modules
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-7814
- Alias
- PYSEC-2026-2866
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
Description
Stored cross-site scripting (XSS) vulnerability in pgAdmin 4 Browser Tree and Explain Visualizer modules. User-controlled PostgreSQL object names (database, schema, table, column, etc.) were assigned to DOM elements via innerHTML, allowing crafted object names containing HTML markup to execute attacker-supplied JavaScript in the browser of any pgAdmin user who navigated to or executed EXPLAIN over the malicious object. Fix replaces innerHTML with textContent. This issue affects pgAdmin 4: before 9.15.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.15 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2026-7814 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/9865 WEB
- https://github.com/pgadmin-org/pgadmin4/pull/9865 WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |