GHSA-6mjg-37cp-42x5

Improper Privilege Management in sap-xssec

At a glance

Published
Updated
CVE
CVE-2023-50423
Aliases
PYSEC-2023-261
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Description

### Impact SAP BTP Security Services Integration Library ([Python] sap-xssec) allows under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application. ### Patches Upgrade to patched version >= 4.1.0 We always recommend to upgrade to the latest released version. ### Workarounds No workarounds ### References https://www.cve.org/CVERecord?id=CVE-2023-50423

Affected packages

PackageVersions
PyPI · sap-xssecintroduced 0, fixed 4.1.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database