GHSA-6m9r-7wrx-xmr6
Apache Airflow Cross-Site Request Forgery vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2023-49920
- Aliases
- BIT-airflow-2023-49920, PYSEC-2023-266
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Description
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 2.7.0, fixed 2.8.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-49920 ADVISORY
- https://github.com/apache/airflow/pull/36026 WEB
- https://github.com/apache/airflow/commit/f5d802791fa5f6b13b635f06a1ea2eccc22a9ba7 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-266.yaml WEB
- https://lists.apache.org/thread/mnwd2vcfw3gms6ft6kl951vfbqrxsnjq WEB
- http://www.openwall.com/lists/oss-security/2023/12/21/3 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |