GHSA-6hr3-44gx-g6wh

Cross-site Scripting vulnerability in drag-and-drop upload of phpMyAdmin

At a glance

Published
Updated
CVE
CVE-2023-25727
Aliases
BIT-phpmyadmin-2023-25727
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger Cross-site Scripting (XSS) by uploading a crafted .sql file through the drag-and-drop interface. By disabling the configuration directive `$cfg['enable_drag_drop_import']`, users will be unable to use the drag and drop upload which would protect against the vulnerability.

Affected packages

PackageVersions
Packagist · phpmyadmin/phpmyadminintroduced 4.3.0, fixed 4.9.11
Packagist · phpmyadmin/phpmyadminintroduced 5.0, fixed 5.2.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database