GHSA-6hpj-9xj7-2jxx

Drupal access control bypass vulnerability

At a glance

Published
Updated
CVE
CVE-2017-6919
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Drupal 8 before 8.2.8 and 8.3 before 8.3.1 allows critical access bypass by authenticated users if the RESTful Web Services (rest) module is enabled and the site allows PATCH requests.

Affected packages

PackageVersions
Packagist · drupal/coreintroduced 8.0, fixed 8.2.8
Packagist · drupal/coreintroduced 8.3.0, fixed 8.3.1
Packagist · drupal/drupalintroduced 8.0, fixed 8.2.8
Packagist · drupal/drupalintroduced 8.3.0, fixed 8.3.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database