GHSA-6h5q-96hp-9jgm

actionpack vulnerable to Cross-site Scripting

En bref

Publiée
Mise à jour
CVE
CVE-2013-6415

Description

Cross-site scripting (XSS) vulnerability in the `number_to_currency` helper in `actionpack/lib/action_view/helpers/number_helper.rb` in Ruby on Rails before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the unit parameter.

Paquets affectés

PaquetVersions
RubyGems · actionpackintroduced 3.0.0, fixed 3.2.16
RubyGems · actionpackintroduced 4.0.0, fixed 4.0.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database