GHSA-699m-mcjm-9cw8

actionpack vulnerable to Cross-site Scripting

En bref

Publiée
Mise à jour
CVE
CVE-2013-4491

Description

Cross-site scripting (XSS) vulnerability in `actionpack/lib/action_view/helpers/translation_helper.rb` in the internationalization component in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted string that triggers generation of a fallback string by the i18n gem.

Paquets affectés

PaquetVersions
RubyGems · actionpackintroduced 3.0.0, fixed 3.2.16
RubyGems · actionpackintroduced 4.0.0, fixed 4.0.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database