GHSA-6859-2qxq-ffv2
pgadmin4 is affected by a Cross-Origin Opener Policy (COOP) vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2025-9636
- Aliases
- PYSEC-2026-1769
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L
Description
pgAdmin <= 9.7 is affected by a Cross-Origin Opener Policy (COOP) vulnerability. This vulnerability allows an attacker to manipulate the OAuth flow, potentially leading to unauthorised account access, account takeover, data breaches, and privilege escalation.
Affected packages
| Package | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.8 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-9636 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/9114 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/cdeb18fcbb139a200b5a4779c82f9cd1aaaf3c89 WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |