GHSA-6757-jp84-gxfx

Improper Input Validation in PyYAML

At a glance

Published
Updated
CVE
CVE-2020-1747
Aliases
PYSEC-2020-96
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

A vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. An attacker could use this flaw to execute arbitrary code on the system by abusing the python/object/new constructor.

Affected packages

PackageVersions
PyPI · pyyamlintroduced 5.1b7, fixed 5.3.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database