GHSA-66c7-5pwv-mm3j

Ansible Code Injection Vulnerability

At a glance

Published
Updated
CVE
CVE-2014-4678
Aliases
PYSEC-2020-203
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.

Affected packages

PackageVersions
PyPI · ansibleintroduced 0, fixed 1.6.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database